E85: Digital Electronics and Computer Engineering
Lab 6: Linear Algebra in C on a Microcontroller

Objective

The purpose of this lab is to familiarize yourself with programming and debugging
in C on an embedded microcontroller. Specifically, you will write some linear
algebra routines that will help you become comfortable with loops, arrays, and
pointers.

1. Welcome to the STM32 Nucleo

The STM32 Nucleo board is a circuit board smaller than 2 x 5 cm at a cost of $11
that has a complete 32-bit ARM Cortex-MO microcontroller with a wide assortment
of peripherals inside. With this board, you could add a microprocessor to a system
for comparable cost to a piece of lumber or pipe.

The Nucleo works with the industry-standard Keil Microcontroller Development Kit
(MDK). You can use the tools in the E85 lab, or can purchase your own STM32F042
and download the free unlicensed version of the MDK-ARM software to use on your
own Windows, Linux, or Mac computer (microUSB cable required). If you install
yourself, make sure you install the STM32F0 device pack during the installation
process. The MDK-ARM software used during Fall 2018 is version 5.25 which can
be found here. The MDK5 Device Family Pack v2.0 can be found here.

2. Keil Tutorial

In this section, you will learn to write, compile, and debug programs with the Keil
MDK.

e Launch Keil uvision from the start menu.
e Choose Project -> New uVision Project to create a new project named ‘tutorial’.
Save it in a new folder in your Charlie directory.

V) \\charlie.ac.hmc.edu\AcadHome\Engineering\E85\Spjut\apongpiriyakarn\lab6_ap\lab6_ap.uvprojx - uVision = O X

File Edit View Project Flash Debug Peripherals Tools SVCS Window Help

A" gl New pVision Project... ® ‘ d
(LJ [ﬁ] @ New Multi-Project Workspace...

Open Project...
Close Project
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e Select the ‘STM32F042K6Tx’ device target using the search box or under
STMicroelectronics -> STM32FO0 Series -> STM32F042 -> STM32F042K6 -> STM32F042K6Tx.

Device I

Vendor:
Device:
Toolset:

Search:

Select Device for Target ‘Target 1'...

<]

ISnﬂware Packs

STMicroelectronics
STM32F042K6Tx
ARM

STM32F042K6

=@ STMicroelectronics
= 4 STM32F0 Series
24 STM32F042

Bt STM32F042K6

-0 STM32F042K6Tx

€1 STM32F042K6Ux

K | i

Description:

STMicroelectronics’ STM32F0 series delivers 32-bit performance while A
providing the essentials of the STM32 family, particularly for cost-

sensmve appllcanons STM32 FO MCUs combine realtime

operation, and the advanced architecture and

P
penpherals assoclmed with the STM32 platform available. This series of
iproducts is highly competitive in traditional 8-bit and 16-bit markets and
eliminates the need to manage different architectures and the
associated development overhead.

Typical applications include application control and user interfaces,
ihandheld equipment, A/V receivers and digital TV, PC peripherals,
\gaming and GPS platforms, industrial applications, PLCs, inverters,
iprinters, scanners, alarm systems, video intercoms, and HVACs

- SRAM with HW parity checking

e In the Manage Run-Time Environment window, expand Device. In the Device Variant
column, choose Standalone. Then check the Startup box. Click on the Resolve button
at the bottom to resolve dependencies and you’ll see that cMsIS (the Cortex

Microcontroller Software Interface System) is selected too. Choose OK.

kA4 Manage Run-Time Environment X

Software Component Sel. Variant Version  Description
‘ CMSIS Cortex Microcontroller Software Interface Components -
‘ CMSIS Driver Unified Device Drivers compliant to CMSIS-Driver Specifications j
® ’ CMSIS RTOS Validation CMSIS-RTOS Validation Suite
R Compiler ARM Compiler 14.0 Compiler Extensions for ARM Compiler 5 and ARM Compiler 6
=] ‘ lWl 1.0.0 Peripheral, Clock and Pin configuration are managed by STM32CubeMX

@ Startup STM32CubeMX 233 System Startup for STMicroelectronics STM32F0 Series

@ STM32Cube HAL l_ Standalone 1.7.0 STM32Cube HAL Drivers ~|
Validation Qutput Description

=4 Keil. STM32CubeMX::Device:Startup
=) require CMSIS:CORE
¥ ARM:CMSIS:CORE

Resolve Select Packs Details

(=) require STM32CubeMX:Device:STM32Cube Framew...
¥ Keil.STM32CubeMX::Device:STM32Cube Fra...

Additional software components required

Select component from list
CMSIS-CORE for Cortex-M, SC000, SC300, ARMvS-M

Select component from list
Configuration via STM32CubeMX

OK I Cancel

Help

i Manage Run-Time Environment

& cMmsis
& CMSIS Driver
€ CMSIS RTOS Validation
® . Compiler
=] 0 Device
¥ Startup v
€ STM32Cube HAL

Software Component Sel.

Variant

ARM Compiler
Standalone

v |1.0.0

Version  Description

Cortex Microcontroller Software Interface Components

Unified Device Drivers compliant to CMSIS-Driver Specifications

CMSIS-RTOS Validation Suite

14.0 Compiler Extensions for ARM Compiler 5 and ARM Compiler 6

1.0.0 System Startup for STMicroelectronics

AllHAL and LL peripheral APIs are selectable as individual components.

e In the project pane, click to expand Target 1. You will see Source Group 1. Click

on the Targetl item, then choose Project -> Options for Group ‘Target 1...".
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File Edit View Projet Flash Debug Peripherals Tools SVCS Window Help

BE=2=N- | New pVision Project...
. @ | New Multi-Project Workspace...

Open Project...

Project a o
=% Project: tutor 10seProject
%5 Target1 Export
J Sour¢ Manage
© Devic
Select Device for Target ...
Remove Iltem
4K Options for Target ‘Target 1°... Alt=F7

Clean Targets

e In the Debug tab, choose Use: ST-Link Debugger (top right area), then click on
Settings, go to the Flash Download tab and choose Erase Full Chip. Click OK then OK
to close the dialog boxes.

Options for Target ‘Target 1' X |

Device | Target | Output | Listing | User | C/C++| Asm | Linker Debug IUliIKiesl

" Use Simulator ~ with restrictions Settings | @ Use: |ULINK2/ME Cortex Debugger _v| Settings | |

™ Limit Speed to Real-Time ULINK2/ME Cortex Debugger A '
ULINK Pro Cortex Debugger

[V Load Application at Startup [V BRun to main() [V Load |CMSIS-DAP Debugger b main()

J-LINK / J-TRACE Cortex

Initialization File: Initializatid Models Cortex-M Debugger
I J Edit | l PEMicro Debugger J Edi |

NULink Debugger

Restore Debug Session Settings Restore .
Stellaris ICDI
] o Ly o = oaldc aillsl INA Nahiinnar
Cortex-M Target Driver Setup Xk
Debugl Trace Flash Download I
Download Function RAM for Algorithm
LOAD % Erase Full Chip ¥ Program N
§q  FeseSecos ¥ Verdy Start: [x20000000  Size: |0x1000
(" DonotErase |~ Resetand Run I

Now, we will create a program that computes the dot product of two vectors.

e (Choose File -> New.... Enter the following code below. Note that it intentionally
contains some bugs. Save your program as ‘tutorial.c’.

// tutorial.c
// Your Name, date, email
// Dot product code to learn the Keil tools
#define DIM 3
double dotproduct (int n, double a[], double b[]) {
volatile int 1i;
double sum;
for (i=0; i<n; i++) {
if (i=0) sum=0;
sum += al[il*ali];
}
return sum;
}
int main (void) {
double x[DIM] = {3, 4, 5}; // x is an array of size 3(DIM)
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tutorial.c(9): warning:

#187-D: use of "=" where "==" may have been intended

double y[DIM] = {1, 2, 3}; // same as y
double dot;
dot = dotproduct (DIM, x, Vy);
return dot;
}

e C(Calculate the dot product of [3 4 5] and [1 2 3] to predict the output of your
program.

e Right-click on the Source Group 1 and “Add Existing Files to Group ‘Source Group 1'...”
and add tutorial.c. You should now see tutorial.c when expand Source Group 1.

Project L | [ tutorial.c o
=-“% Project: tutorial 1// tutorial.c
=7 Target 1 2 // Your Name, date, email
il Fr——ae 1 2 /[ Dar nrodunct code to learn the Keil tools
‘ De ,z;\ Options for Group ‘Source Group 1'... Alt=F7
uct (int n, double a[], double b[]) {
Add New Item to Group ‘Source Group 1'... int i:
Add Existing Files to Group ‘Source Group 1'... ;
o i<n; i++) |
Remove Group ‘Source Group 1' and its Files o~ — .
i=0) sum = 0;

e C(Choose Project -> Build Target to compile (or click & on the top panel; or press
F7). Scroll through the Build Output panel at the bottom to look for warnings
and errors. You will see a warning that the (i=0) comparison should have
been (i==0). Change your code to correct this and rebuild and ensure there
are No errors or warnings.

Project L x| ] tutorialc vx

=% Project: tutorial 1// tutorial.c ~

=57 Target1 2 // Your Name, date, email
3 [={ Source Group 1 3 // Dot product code to learn the Keil tools
q J tutorial.c 4 #define DIM 3 )
’ A 5 doubkle dotproduct (int n, doukle a[], doukle b[]) {
Device 6 volatile int i;

7 doubkle sum;
8 for (i=0; i<n; i++) {
g if (i=0) sum = 0;
10 sum += af[i]*a[i];
11 }
12 return sum;
13}
14 Iint main (void) {
15 double x[DIM] = {3, 4, S}:
16 doukle y[DIM] = {1, 2, 3};
17 double dot;
18 dot = dotproduct (DIM, x, v):
19 return dot;
201} 4

[ — [ >

Build Output I x|

*** Using Compiler 'V5.06 update 6 (build 750)', folder: 'f:\Keil v5\ARM\ARMCC\Bin'

Build target 'Target 1°'

compiling tutorial.c...

if (i=0) sum = 0;

tutorial.c: 1 warning, 0 errors

e Make sure a Nucleo board is plugged and connected via a USB port.
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e Choose Debug -> Start/Stop Debug Session to invoke the debugger (or press Ctrl
then F5). You should see a yellow arrow pointing to the beginning of the main
function.

File Edit View Project Flash Debug Peripherals Tools SVCS Window Help

=" | @‘ [ @&y @} start/Stop Debug Session Ctri=F5 | [ k) v B ﬁ[ @ v| Y &
. E\.' Energy Measurement without Debu
2] ) 2 - 5| tar & ’
| Project 1 B 24 Reset CPU v X
— #e Do .
1 =*% Project: tutorial 2l Run F5 ~
= 37 Target1 —
5 B2 Cavniera Cennn 1 @ stop fhe ®eil tonla

e Use the Step command ( 0" " "0 on the icon bar, or press F11) to step
through your code. You can watch the variable addresses and values in the
Call Stack + Locals pane in the lower right. Make it bigger so you can see
everything. Expand the x and y arrays so you can see their values. As you
step through the first two lines, you should see arrays getting initialized. The
compiler aggressively optimizes the code, so sometimes you will see weird
things in the debugger or variables not changing when you expect them to
change. 11s declared as volatile in this code to force it to be preserved by the
optimizer and appear in the debugger.

Registers 2 El Disassembly
Register | Value I_: e
= o>0x08000944 B530 PUSH {r4-r5,1r}
0x08000946 BOSD sSUB sp, sp, #0x34
0x08000948 2218 MOVS r2,#0x18
0x0800094A 490B LDR rl, [pc,#44] ; @0x08000978
0x0800094C A8B06 ADD x0,sp, #0x18
0x0800094E F7FFFBFB BL.W __aeabi _memcpy4 (0x08000148)
0x08000952 2218 MOVS r2,#0x18
0x08000954 4908 LDR rl, [pc, #32] ; @0x08000978
0x08000956 3118 ADDS rl,rl,#0x18
OxFFFFFFFF b

OxFFFFFFFF
R10 0x080005C0O
R11 0x080005C0O iy !
R12 OxFFFFFFFF 12  return sum;
R13 (SP) 0x20000660 13}

L] tutorial.c ] startup_stm32f042x6.s

R14 (LR) 0:08000137 P> 14 int main(void) ¢
R15 (PC) 0x08000944 15 double x[DIM] = {3, 4, 5}; // x is an array of size 3(DIM)
+-xPSR 001000000 16 double y[DIM] = {1, 2, 3}; // same as y
+ Banked 17 double dot;
(- System 18 dot = dotproduct (DIM, x, V);
R > 19 return dot;
(] Project | = Registers <
Command o EJ Call Stack = Locals
Toad mMA\\chazlie. s mme. edu\\AeadHome\\E \\EES\\Sp3uci\ Neme tocstion/Value Tope
oad " charlie.ac.hmc.edu\\AcadHome ngineerin 8 jut\\apon
e e me ginee: g )] PONgE -9 main 0x08000944 intf()
@@ x 0x20000638 auto - double[3]
[ Y 0x20000620 auto - double[3]
¢ dot 1.491668190696e-154 | auto - double

< >

>
ASSIGN BreakDisable BreakEnable BreakKill BreakList BreakSet BreakAccess | A Call Stack + Locals |jr\en‘mm

e Find the bug that causes the dot product to be incorrect. Fix your code. Use
the debugger (Debug -> Start/Stop Debug session), then rebuild the code, download

1t again.

3. Linear Algebra

The goal in this section 1s to write a library of linear algebra routines in C. This will
help you get accustomed to loops, arrays, and pointers in C, and it is good to
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understand these routines because they are fundamental building blocks of signal
processing code.

Mathematical operations that you will be writing include matrix addition, linear
combination of matrices, matrix transpose, matrix equality, and matrix
multiplication.

The following functions operate on matricies of m rows and n columns (m x n). You
may assume that the result matrix have already been allocated prior to the function
call. The transpose function produces an n x m result. Function declarations are
given below:

void add(int m, int n, double *A, double *B, double *Y); //Y=A+R
void linearcomb (int m, int n, double sa, double sb, double *A, double *B, double *Y);
//Y=sa*A + sb*B
void transpose (int m, int n, double *A, double *A t);
//A t=transpose (A)

int equal(int m, int n, double *A, double *B); //returns 1 if equal, 0 if not

The last function multiplies an m1 x n1m2 matrix A by an n1m2 x n2 matrix B to
produce an m1 x n2 matrix Y. Y should already be allocated and the contents will be
overwritten. The following is the function declaration.

void mult (int ml, int nlm2, int n2, double *A, double *B, double *Y); //Y=A*R

Now 1is your turn to program.

e Write a C program to complete five operations given above

e Test your program with the following code, using the newMatrix and
newIdentityMatrix code from lecture. Remember that you will need to
include the standard library that has the malloc function using the
statement: #include <stdlib.h> at the beginning of your code.

#include <stdlib.h> // for malloc

double* newMatrix (int m, int n) {
double *mat;
mat = (double*)malloc (m*n*sizeof (double)) ;
return mat;

}

double* newIdentityMatrix (int n) {
double *mat = newMatrix(n, n);
int i, Jj;
for (i=0; i<n; i++)
for (3=0; j<n; J++) {
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mat[j+i*n] = (i==3);
return mat;

}

int main (void) {

double v1[3] = {4, 2, I // 1x3 vector

double v2[3] = {1, , I // 1x3 vector

double dp = dotproduct (3, vl, v2); // compute vl dot v2
double mi1[9] = {0, O, 2, O, O, O, 2, O, I // 3x3 matrix

double *m2 = newldentityMatrix(3); // 3x3 identity matrix
double *m3 = newMatrix (3, 3); // 3x3 matrix

double m4[6] = {2, 3, 4, 5, 6, I // 3x2 matrix

double *m5 = newMatrix (3, 2); // 3x2 matrix

double m6[6] = {6, 2, 5, 8, 2, I // 2x3 matrix

double *m7 = newMatrix (3, 2); // 3x2 matrix

double *m8 = newMatrix (3, 2); // 3x2 matrix

double expected[6] = {2, 1, 0, 1, O, I // expected result matrix
int eqg;

add (3, 3, ml, m2, m3); // m3= ml+m2

mult (3, 3, 2, m3, m4, mb); // mb= m3*m4 (3x2 result matrix)
transpose (2, 3, m6, m7); // m7= m6”"t

linearcomb (3, 2, 1, 1-dp, m5, m7, m8); // m8= 1*m5 + (l-dp)*m7

eq = equal (3, 2, m8, expected); // check if m8 is as expected
return eqg; // return 1 if so; 0 otherwise

e Predict what each of the matrices should be and particularly check that m8
matches your expectations.

e You'll find it frustrating in the debugger watch window that when you look at
a pointer variable such as m2, you only see the Oth element. However, the
watch window (open from View menu) allows you to enter expressions. You
can type in particular elements such as m2[4] to have them displayed for you.

4. Extra Credit: Solving Systems of Linear Equations

Write a C function to invert an n x n matrix. If the matrix is singular, the function
should return 0 and Y is a don’t care; otherwise, the function should return 1 and Y
is A™1. Use the following function declaration:

int invert (int n, double *A, double *Y);
Then write a function to solve for x in Ax=Db for a system of n variables.
int solve (int n, double *A, double *b, double *x);

The function should again return 0 if A is singular.

Use your function to solve the following system of linear equations:
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3a + b+ c+d=26
2a + 3b + 4c — d = 12
-4a + d =8

3b — 2c =0

Note that your new program may hang from lack of memory. Comment out the test
code from the previous part or use free to free up some space. Be careful in your
memory allocation and dellocation, particularly if you are using a recursive
determinant function. A malloc that fails for lack of memory will return a NULL
pointer (with an address of 0).

What to Turn In

1. Please indicate how many hours you spent on this lab. This will be helpful for
calibrating the workload for next time the course is taught.

2. Code for add, 1inearcomb, transpose, equal, and mult.
3. What does your code produce for m8? Does it match your expectations?
4. Extra credit, if applicable. Give your code and a, b, ¢, and d.

Please indicate any bugs you found in this lab manual, or any suggestions you
would have to improve the lab.
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