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E11: Autonomous 

Vehicles 
Fall 2010 
Harris & Lape with Keeter & Ong 

 

Lab 2: 3D CAD and 

Printing 

The goal of this lab is to create a robot chassis in SolidWorks that can be printed on HMC’s 3D 
printer.  When you are done, the chassis should look like the one below.  

 

Introduction 

SolidWorks is a computer-aided design (CAD) program for modeling 3-dimensional objects.  
Using CAD tools, engineers can create models ranging from a single component to a fully-
ssembled machine.  In this lab, you will create a single part: the chassis of your robot. When 
designing a part in SolidWorks, you will start with a two-dimensional drawing, called a Sketch.  
This sketch is then converted into a Feature to give it depth in the third dimension.  By extruding 
sketches on various planes, complex parts can be created. 
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Constraints 

CAD tools are meant to create parts for the real world, which means that each part must be fully 
dimensioned.  Under the hood, SolidWorks stores a set of constraints that define a drawing.  
These constraints specify length, orientation, angle with respect to other objects, or many other 
characteristics.  It is important to make each drawing fully defined, so that there is no uncertainty 
in the shape of the part.  A fully defined line will show up in black; an undefined line will be 
drawn in blue. 

3D Printing 

A 3D printer is an additive manufacturing technology that builds up a 3-dimensional object with 
successive layers of material.  The HMC Dimension SST 1200 3D printer constructs objects 
from white ABS plastic.  The printer also uses a soluble black support material, which is used to 
hold up the building material.  This support material is then dissolved away. Since a part is built 
upward in 10-mil layers, any layer that is larger than the lower layer requires support material to 
hold itself up while printing. The process costs approximately $10/in3 of building material. 
Support material is less expensive, but it is nevertheless a good idea use no more than necessary.   

To minimize printing time and cost, you will build a chassis that is made as thin as is practical 
and has cutouts to reduce volume.  The design consumes less than 2 in3 of printing material, and 
prints in about 2 hours. 
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Getting started 

First, log in to a computer in the Engineering Computational Facility (ECF).  Double-click on the 
SolidWorks icon: 

 

This will open SolidWorks Education Edition 2009-2010. *** update 

The entire chassis will be a single part.  Click on the New Document button in the upper left 
corner.  Make sure that Part is selected, and click Ok. 
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Helpful Tips & Tricks 

Here are a couple shortcuts and other debugging skills that might be helpful as you go along. Keep this 
page handy throughout the tutorial.  

1. Escape Key 
The escape key up on the top left of your keyboard will become your best friend. If ever you triggered 
a command you didn't mean to, pushing escape will cancel the command.  
          Ex: You finished drawing a contour or centerline, but it seems to want to keep drawing.  
          Pushing 'Esc' will keep what you've already drawn, while getting you out of the drawing mode.  

2. Ctrl+Z: How to undo a mess 
If you don't want to bother with re-dimensioning something, finding the convoluted way to delete a 
sketch or are just fed up and think it's easier to just do the whole step over again, Ctrl+Z will undo the 
last step. If you Ctrl+Z too many times, use Ctrl+Y to redo.    

3. Click & Drag to select parts of a sketch 
Helpful for selecting multiple parts of a sketch. Instead of holding control while clicking each line 
segment, you can draw a selection box by holding down the left mouse button and dragging it across 
the screen. The place you clicked and the location of your mouse will form two opposite corners of 
the selection box.  
          Note: this will only work to select things in the current sketch you are editing. This will not   
          highlight previous sketches or features. 

4. Feature vs. Sketch: Extrude out? Extrude cut? or Oops, I forgot to select a feature! 
A sketch is a 2D representation, like a sketch on paper. A feature is what is added to a sketch to make 
it 3D. Note that a sketch always precedes a feature.  
          Step 1: Removing an incorrect feature from a correct sketch 
          Right click on the incorrect feature, choose delete. The sketch should still be there.  
          Step 2: Your sketch is awesome and complete, but there's no feature attached! 
          Click on the sketch name in the left panel, and then click the correct feature button.  

5. Rotating the component 
Holding down the middle mouse button while moving the mouse around allows for viewing the part 
at any angle. This can be useful for amusing yourself as well as other more practical purposes. 
          Ex: When in Features, editing the extrusions, SolidWorks will put in a phantom projection of  
          what it will look like. You can view it by rotating your piece, checking if the proportions and  
          locations of the extrusions/cuts are visually correct. 

6. Editing Smart Dimensions 
When in sketch mode, you can change an already placed dimension by double clicking on the 
dimension. This only works if you are not in Smart Dimension mode (use Esc). It is not necessary to 
delete the dimension and reenter it. 

7. Zooming 
To zoom in and out, use the scroll (middle mouse button). It will zoom in/out centered around the 
location of your mouse. Or, you can press the 'f' key to make the part 'fit the screen'.  

8. Save Often 
To save your work, click on the Save icon at the top of the screen or press Ctrl-S. 
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Starting the base 

Now, we’ll get started with drawing the part.  We want the base to be a single rectangle, centered 
on the origin.  In the Sketch tab, click on the arrow next to the rectangle, and select Center 
Rectangle. 
 

 

A set of planes should show up in the main window.  Click on Top Plane.  This means you’ll be 
seeing the part from above.  At this point, you should change perspective to make drawing more 
intuitive.  There is a button on top of the main window that lets you select a perspective- this is 
the View Orientation button.  Use it to shift into downward-looking viewpoint. 

 

Now, click in the very center of the plane (the cursor should show an orange dot) and draw a 
rectangle- the exact size does not matter. 

All of the lines defining this rectangle are blue.  That’s because the rectangle doesn’t yet have 
any associated dimensions.  To assign dimensions, click on Smart Dimension in the upper corner 
of the Sketch tab. 
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Click on the rectangle’s left side, move the cursor a bit to the left, and click again to place the 
dimension on the sketch.  At this point, a window should pop up allow you to set the dimension.  
We want the rectangle to be 3” by 5”, so enter 3 in the window and click the check box.   

 

Now, repeat the process for the long side, making it 5” long.  All the lines of the rectangle should 
now be black, and you should see “Fully Defined” in the status bar at the bottom of the screen.  
We’re all done with the sketch, so click on Exit Sketch in the upper left corner of the Sketch tab.  

Now, we’re going to push the sketch into the 3rd dimension!  Switch to the Features tab, and 
select Extruded Boss/Base with Sketch1 selected.  
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Select a depth of 0.2 inches, and click on the green check mark. 

 

You should now see a rectangular prism in the main window.  Hold down the middle mouse 
button to spin around the part; press ‘f’ to zoom to the extents of your part. 

Next, we will cut out excess material on the front of the robot.  In the Features tab, select 
Extruded Cut.  Note: do not choose Extruded Boss/Base. 
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SolidWorks now asks for a plane on which to draw- this is what’s known as the sketch plane.  
Click the top face of the rectangular prism.   

Note: If you’ve gotten disoriented from all your spinning, remember that you can reorient 
yourself using the View Orientation button at the top of the window to return to the top view. 

This time, select a Corner Rectangle from the Sketch tab.  Draw a rectangle from the bottom 
right corner up.  SolidWorks is enthusiastic about snapping sketches to existing lines and corners 
in the drawing.  Visual cues should indicate when the rectangle is snapping to the corner of the 
base.  Again, the exact size doesn’t matter, since it will change when you apply dimensions to 
the rectangle.   

Use Smart Dimension to define the rectangle as 1” by 0.8”.  You should end up with the 
following: 

 

To save on effort, we will now mirror this rectangle along the long axis of the base.  Select 
Centerline in the Sketch tab.  This tool will be very useful for making symmetric parts. 

 

The centerline should connect the midpoints of the left and right sides of the base.  Move the 
mouse along the left side of the base.  When you are near the middle, an orange square should 
appear, indicating the midpoint of the line.  Click on the square to start the centerline, move 
horizontally to the right side's midpoint, and click again to place a vertex.  Press Esc once or 
Enter twice to complete the line. 
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Select the rectangle that you’ve just drawn and the mirror line (either hold the Ctrl key and click 
multiple times or Click & Drag to select multiple items - refer to Helpful Tips & Tricks).  Now, 
click Mirror Entities in the Sketch tab.  SolidWorks will automatically decide that you want to 
mirror about the centerline.  It should reflect the rectangle onto the upper half of the base.  Now, 
exit the sketch.  A new options menu for the Extrude command should appear on the left hand 
side of the screen.  In the options for Extrude, change “Blind” to “Through All”.  This will 
ensure that if you change the thickness of the base, the cutouts will still go through the entire 
thing.  Click the green checkmark, and admire your work. 

 

Believe it or not, the basics that you’ve just learned will allow you to make all kinds of complex 
parts.  At this point, let’s take a break and rename the steps that you’ve taken.  In the panel on the 
left side of the screen, you’ll see “Extrude 1” and “Extrude 2”.  These aren’t very descriptive 
names!  Click on the text twice to change it. (Don’t double-click; wait a moment between the 
consecutive clicks.)  “Base” and “Front cutouts” are better names for these steps.  When keeping 
track of a complex part, descriptive names save a lot of time!  If you ever need to go back to 
correct a step, you can click on that step and adjust dimensions as necessary, or even delete the 
entire step.  You may also add new corrected steps and rearrange the order of steps.  We won’t 
keep reminding you, but as you go through this tutorial, it’s a good idea to change the default 
names after each step. 

This is a great time to save your work. Save again at regular intervals as you go. 

Cutouts for gearbox and motors 

It’s time to add an inset for the gearbox and motors.  Again, select Extruded Cut and click on the 
top face of the base.  First, draw a centerline across the base.  Then, in the Sketch tab, select Line 
and draw something like the following: 
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Be careful to keep that the lines stay either horizontal or vertical.  Make sure that the line starts 
on the side of the base, and ends on the centerline.  SolidWorks gives you visual cues (e.g. 
changing colors) to show when it’s snapping points to other lines on the drawing.   

We want this shape on both sides of the centerline.  Again, select all of the lines and the 
centerline; press Mirror Entities in the Sketch tab to make a reflection.  Make sure that the 
contour is closed- if there isn’t one already, draw a line from the top left to bottom left vertex.   

Now, use Smart Dimension to give this shape dimensions.  Observe that as you set dimensions 
on the bottom of the sketch, the top half adjusts itself to stay mirrored. Make sure the piece is 
fully defined. 

Note: You do not want to over define the sketch. If there is a warning box asking if you want to 
make a dimension 'driven', that indicates the dimension you are trying to add is unnecessary. 
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Now, exit the sketch.  Set the extrusion’s end condition to “Blind”, and pick a depth of 0.1”.  
This will cut part way through the body.  Complete the extrusion, and look over your work. 

Satisfied?  Good! 

The gearbox has screw holes that make it easy to attach.  We can punch holes through the base 
for these screws.  Select Extruded Cut, with the gearbox inset as your sketch plane.  Select Circle 
from the sketch tab, and draw a circle inside the tab at the bottom of the cutout.  As always, exact 
dimensions don’t matter at this stage. 

Using Smart Dimension, click on the outside of the circle.  You’ll create a diameter dimension; 
set it to 0.12”.  The circle’s size is now defined, but you still need to give it a location.  Click on 
the center of the circle, then on the line on the left side of the tab: 
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This sets the perpendicular distance from the edge to the center.  You want this value to be 0.24”.  
Similarly, set the distance between the circle’s center and the bottom of the inset at 0.18”.  The 
final set of dimensions should look like the following: 

 

As before, mirror this circle about a centerline, then exit the sketch.  Set the extrusion mode to 
“Through All”, and make sure that everything looks correct: 

 

Phototransistor tower 

There are two steps remaining in the guided part of this lab: extrude a tower for the 
phototransistor, then cut a hole in it.  This tower will go on the front of the robot.  To start, select 
Extruded Boss/Base from the Features tab.  Select the top level of the base as your sketch plane.  
As usual, it will be helpful to put down a centerline.  Draw a Center Rectangle on the centerline, 
then apply the following set of dimensions: 
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Extrude the tower up by 1”.  The phototransistor will rest inside this tower, but it needs a hole in 
which to sit.  Start making an Extruded Cut, and select the front of the tower as the sketch plane.  
At this point, it might be helpful to adjust your view so that you’re looking at the front of the 
chassis.  Draw a centerline down the tower, and draw the following circle: 

 

Now exit the sketch, and select “Up to Next” as the extrusion type.  This will cause the hole to be 
cut through the tower, but not any farther.  At this point, your chassis should look like the 
following: 
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Identification Label 

Put your name on the bottom side of the robot chassis so you’ll be able to identify your robot 
after it is manufactured.  Use an extruded cut.  Choose the text tool.  Enter your initials.  The 
default font isn’t very readable.  Uncheck the “Use Document Font” box and click on Font.  
Choose Arial Black and set the height to 0.2 inches. Apply dimensions to place it in a good 
location. Set the depth to 0.05 inches. 
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Boldly onwards! 

Now, look at the drawing of the completed chassis.  You will see that you are missing various 
important pieces: 

• Corner holes for attaching PCB 
• Square hole for the reflectance sensor 
• Pair of holes for attaching caster wheel  
• Support structure for phototransistor tower 
• Front bumping plate 
• Miscellaneous cutouts to reduce part volume 

 

The drawing has enough information for you to add these pieces to your own chassis.  Proceed 
boldly onwards, and ask your instructor for clarification if you have any questions.   
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When you have finished, check how much material your chassis will use. This can be found in 
the toolbar that slides out when you hover your cursor on the SolidWorks logo in the upper left 
corner. Try Tools --> Mass Properties. The standard bot should have a volume of 1.87 in3, minus 
a very small amount (e.g. 0.01 in3) due to the initials.  If this is correct, ask your instructor to 
check off your completed drawing. 

Preparing for 3D printing 

Finally, write out your design to a printable file format. In order to see the upper menus, hover 
the cursor on the SolidWorks logo in the upper left corner.  Go to File -> Save As.  Change 
“Save as Type” to STL (a stereolithography file format), and name the file “username_bot.stl” 
(i.e. Ben Bitdiddle’s bot would be named “bbitdiddle_bot.stl”).  That’s all you need to do to 
make your chassis ready for the 3D printer! 

Email your .stl file to the ECF Systems Administrator, willie_drake@hmc.edu.  In the subject 
line, indicate “E11 3D print request for <username>” with your username. 

If you wish to print designs in the future for your coursework or for personal projects, contact 
Willie Drake for a 3D Printer Request form.  Complete the form and send in the file. You are 
responsible for the cost ($10/in3) of future designs you print after this laboratory.  Bring a check 
made out to Harvey Mudd College to Cynthia Wheeler in the Engineering Department Office. 

	
  


